No Power to HVAC Unit

Reply

  #1  
Old 11-06-17, 10:39 PM
Member
Thread Starter
Join Date: Sep 2015
Posts: 26
Received 0 Votes on 0 Posts
No Power to HVAC Unit

Hello everyone.

This is regarding a Luxaire Furnace Model G8T06012UHA11A. As of 48 hours ago the system was running without issue.

I cam home from work toady and switched the unit to heat and got nothing. Upon inspection and turning the power on and off I noticed there was no audible "hum" from the transformer which previously was always noticeable. I turned the fan on at the thermostat and get nothing; no clicks, hums, nada.

So, I removed the transformer thinking maybe it took a crap, but the resistances on the primary and secondary both check out. Circuit breaker is fine. Fuse on the board is fine. When power is going to the unit the light on the board is out. I've given all the wires a little jiggle with power to the unit and no signs of life from the control board light.

Thoughts? Dead board?

Thanks.
 
Sponsored Links
  #2  
Old 11-06-17, 10:46 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 54,219
Received 478 Votes on 448 Posts
Check for 120vac TO the transformer and check for 24vac OUT of the transformer.

Remember.... there is a safety switch on the blower door that kills the entire system.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: