Lennox Gas Furnace Wouldn't Start - Gas valve is cycling quickly

Reply

  #1  
Old 11-07-17, 10:39 AM
Member
Thread Starter
Join Date: Aug 2010
Location: USA
Posts: 9
Received 0 Votes on 0 Posts
Lennox Gas Furnace Wouldn't Start - Gas valve is cycling quickly

About one week ago I noticed my Lennox gas furnace would start with some issues. Every time there is call for heating, the gas valve would open and once ignition is successful for less than 1 sec. then the gas valve would close and all flames are gone. it would do something like this several times and eventually the flame is stable and then furnace would run properly.

Yesterday evening I noticed the furnace would not start. The burner blower would run first but then the gas valve would cycle quickly without ignition. I checked the voltage to the gas valve and it's changing between 0-0.5V (got same readings on circuit board itself) and it should be 24V. checked wire continuity between circuit board and gas valve and everything is fine. I suspect the circuit board is shot. Any suggestions?

Furnace model is 80MGF3-75A-2 and circuit board appears to be EGC-2

Thanks.
 
Sponsored Links
  #2  
Old 11-07-17, 12:17 PM
Member
Join Date: Jun 2012
Location: USA
Posts: 1,412
Received 12 Votes on 11 Posts
Could just be a dirty flame sensor. What is the diagnostic code from the pattern of the LEDs flashing?
 
  #3  
Old 11-07-17, 12:40 PM
Member
Thread Starter
Join Date: Aug 2010
Location: USA
Posts: 9
Received 0 Votes on 0 Posts
diag. LED shows no warning or alarm. Note there is no flame at all since 2 days ago. Doesn't appear the flame sensor is broken since usually the furnace will allow 10 seconds for ignition trial. 1 week ago, the gas valve would close quickly once ignition is successful and this repeated several times. In both cases, there is no 10 sec. period of ignition trial.
 
  #4  
Old 11-07-17, 03:12 PM
Member
Join Date: Feb 2014
Location: USA
Posts: 2,104
Received 0 Votes on 0 Posts
Does the ignitor glow each time ?
 
  #5  
Old 11-07-17, 03:20 PM
Member
Thread Starter
Join Date: Aug 2010
Location: USA
Posts: 9
Received 0 Votes on 0 Posts
no, starting from 2 days ago, no more energized ignitor. The ignitor appears to be spark type and if it's energized, you can hear the clicks (usually multiple clicks), just like gas stove.
 
  #6  
Old 11-07-17, 03:50 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 52,653
Received 340 Votes on 318 Posts
That is a direct spark type intermittent ignition.

It is not a flame sense issue. If the flame sense circuit senses any lapse in flame rectification.... it shuts the gas valve and continues with a post purge. Then the cycle starts again. It will not allow the gas valve to chatter.

If the 24vac coming out of the board to the gas valve is not stable..... you have a defective control board..... most likely a defective valve relay.

Your manual... Lennox80MGF.pdf
 
  #7  
Old 11-07-17, 05:48 PM
Member
Thread Starter
Join Date: Aug 2010
Location: USA
Posts: 9
Received 0 Votes on 0 Posts
Originally Posted by PJmax View Post
That is a direct spark type intermittent ignition.

It is not a flame sense issue. If the flame sense circuit senses any lapse in flame rectification.... it shuts the gas valve and continues with a post purge. Then the cycle starts again. It will not allow the gas valve to chatter.

If the 24vac coming out of the board to the gas valve is not stable..... you have a defective control board..... most likely a defective valve relay.

Your manual... Lennox80MGF.pdf
Thanks. I got same copy. It mentioned circuit board EGC-2. Checked my furnace and its circuit board version is EGC-1. On the drawing they look similar. Hopefully a friend of mine can find it somewhere. According to local regulation, they cannot sell it to people who are not licensed gas tech.
 
  #8  
Old 11-09-17, 06:26 AM
Member
Thread Starter
Join Date: Aug 2010
Location: USA
Posts: 9
Received 0 Votes on 0 Posts
PJMax, I have difficulty to find the circuit board from suppliers. Seems it's discontinued. Only place I can find used ones is ebay.

https://www.ebay.ca/itm/272767504905?ul_noapp=true

The version for this one is EGC HB-00907DA EGC-2 73K8001

The version on my furnace is EGC HB-00907DA Ver 1F, EGC-1 Cat# 73K79 9750

Do you think the one on eBay would work?

Thanks.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description:
Your question will be posted in: