Honeywell T5+ Thermostat issue

Reply

  #1  
Old 08-19-19, 09:02 AM
Member
Thread Starter
Join Date: Aug 2019
Posts: 1
Upvotes: 0
Received 0 Votes on 0 Posts
Honeywell T5+ Thermostat issue

I have a Burnham ES2 boiler in the basement, a Honeywell T5+ Thermostat and a Bryant central AC unit with the air handler in the attic. I connected all of the following wires as they were on the original old thermostat. From heating unit: Rh and W. From A/C unit: Rc, G, and Y. I had an extra wire going downstairs to the boiler which I used for the C wire. When I connected it (the C wire)to the terminal block common post in the boiler, the thermostat came on, I can program it, and I can run the heat. However, when I turn on the breakers for the AC unit the thermostat shuts off. I cannot figure out where the conflict is so I put back the old thermostat for now. Any ideas?
 
Sponsored Links
  #2  
Old 08-19-19, 09:19 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 51,950
Received 265 Votes on 248 Posts
Welcome to the forums.

The conflict is that the C common MUST connect at the air handler or A/C system.
 
  #3  
Old 08-19-19, 10:16 AM
Member
Join Date: Jan 2019
Location: Southern Arizona
Posts: 62
Received 2 Votes on 2 Posts
T stat

Get the manual for the stat and read to see if you can use a boiler with it. Boilers a a bit different and most stat companies make a bunch of models for different applications.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description:
Your question will be posted in: