Need help w/Goodman gas furnace


  #1  
Old 10-14-19, 11:06 AM
I
Member
Thread Starter
Join Date: Oct 2011
Location: USA
Posts: 1
Upvotes: 0
Received 0 Upvotes on 0 Posts
Need help w/Goodman gas furnace

Our GMT115-5 turns on when we raise temp at thermostat, runs for 30 seconds and shuts off. Tested and replaced pressure switch, check igniter and cleaned with emery cloth. No flame, no hot glow. Filter is not the issue. What do we try next?
P.S. Furnace has had 2x year maintenance by HVAC pro, 14 yrs old, never any problems but figure it's about due ;-) Only other thing I can think of is bad gas valve...have HVAC coming but wanted to try and troubleshoot if possible.
Thank you in advance!
 
  #2  
Old 10-14-19, 12:54 PM
user 10's Avatar
Member
Join Date: Mar 2004
Location: NA
Posts: 1,829
Received 57 Upvotes on 50 Posts
what happens when it tries to run?

describe sequence of operation.

gas valves rarely go bad.
 
  #3  
Old 10-14-19, 01:25 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Jersey
Posts: 65,494
Received 4,056 Upvotes on 3,639 Posts
I agree..... gas valves rarely go bad.
Many people change them and declare the problem fixed when all it was a connection problem.

Your furnace has a control board with a diagnostic LED. Reset power to the furnace.
Observe what the LED flashes. It should flash a trouble code sequence.
 
  #4  
Old 10-14-19, 01:54 PM
R
Member
Join Date: Oct 2016
Posts: 2,183
Received 199 Upvotes on 181 Posts
If the hot surface ignitor isn’t glowing it’s not the gas valve.
Is the ignitor getting voltage? Test with your meter.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: