Nuvi 260W >Garmin GPS<

Reply

  #1  
Old 10-20-12, 12:03 PM
Member
Thread Starter
Join Date: Mar 2008
Location: Southern New Jersey
Posts: 231
Nuvi 260W >Garmin GPS<

I'll try out your new forum. I have a Garmin 260W. It's a few years old but I have lifetime updates. I don't use it a lot. ( I don't really go anywhere ) I bring it out to the car and plug it in just to use it. Anyway I updated it a week or so ago. I just plugged it in to use it and did actually use it to take a short trip. Anyway the thing seems to have gone stupid. First it came out speaking Afrikaans??? I fixed that easy enough but the voice is just different....more halting. Anyway I knew the general area I was going just not the exact location. I was forcing it to take my route cross-country instead of the highway figuring when it got close to the area it would readjust. Nope. I was about a mile from my destination and it was still trying to U-turn me. Is there another setting I am missing that may have gotten "updated" amiss?
 
Sponsored Links
  #2  
Old 10-20-12, 01:14 PM
GregH's Avatar
Super Moderator
Join Date: Jan 2001
Location: Manitoba
Posts: 9,628
I wonder if the update you used was the correct one.
I know someone with a different model Nuvi who updated and the only change was with the maps.

I checked here and they have a choice of 16 different update options.
There should be a menu choice that lists the map and update version.
 
  #3  
Old 10-20-12, 04:14 PM
chandler's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Dec 2005
Location: USA
Posts: 39,968
Also set the GPS to shortest distance or fastest route. Yours may be set to another one that will take you cross country. I have a Garmin 1450 LMT with the lifetime updates, and haven't had such a problem. You need to get the right one as Greg mentioned. It may be trying to get you to Africa via a land bridge
 
  #4  
Old 10-22-12, 12:44 PM
Member
Thread Starter
Join Date: Mar 2008
Location: Southern New Jersey
Posts: 231
Nuvi 260W

I forgot about the settings for fastest route, no tolls, etc. Next time I plug it in I'll dig deeper. As for the updates I seem to remember there wasn't a lot of choices... just a basic update
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 05:26 AM.