Heat pump compressor gone bad AGAIN

Reply

  #1  
Old 03-08-05, 10:46 AM
anderjosh
Visiting Guest
Posts: n/a
Question Heat pump compressor gone bad AGAIN

This will be the third compressor that weve had to replace in 8 months. When we started having problems we replaced just the compressor. Once that compressor went bad, we were instructed to replace the entire unit,(everything)!

Our last two heating bills were $240.00+ for 1280 sq ft home. So we called the HVAC people out to diagnose the problem, they are telling us our compressor is bad again, but offer no explanation, just a $550 quote to replace it. What could be causing our compressor problems

Thanks
 
Sponsored Links
  #2  
Old 03-08-05, 04:06 PM
Grady's Avatar
Forum Topic Moderator
Join Date: Jan 2005
Location: Delaware, The First State
Posts: 13,928
Question Third Compressor

Sounds like you need to call another service company. There is something causing compressors to go bad. Once that problem is found & fixed your troubles should be over. If the first compressor "burned out" & the entire system was not flushed, residual acid could be taking out the new compressors. No warranty on the existing unit? What kind of equipment? Package or split system?
 
  #3  
Old 03-08-05, 04:27 PM
Ed Imeduc's Avatar
Member
Join Date: Aug 2002
Location: Mountain Williams Missouri
Posts: 18,389
Thumbs down

With Gardy here I dont think they cleaned the lines and coil right. Did they put a new drier in for clean up of the heatpump.
By everything do you mean inside and out side on the units? If they put a new outside unit in then you should have 1 year on everything in it and 4 more years warranty on the compressor. I think Id call the BBB there and ask about this company you have.
might go to http://www.warmair.net and see what fuel cost less there oil gas or electric

ED
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes