Help with Honeywell RTH7500D


  #1  
Old 03-24-05, 04:36 PM
s_o_wise
Visiting Guest
Posts: n/a
Freezing! Need Help w/ Honeywell RTH7500D

Ok, about a month ago I bought and connected the Honeywell RTH7500D digital stat to replace the out of date analog/ mercury one. According to the guy at Home Depot I needed this one? Ok I know my voltage is 24 volts, I know that I have an 8 year old HEIL heating and A/C system the original stat has heat, cool, off, emergency and the fan auto, on.

Well the past two weeks my system has stopped working and there is no heat. It says the heat is on the fan is blowing but no hot air. Ambient room temp is 60 degrees now and the stat was set at 73 degrees. I need some help. I am re checking the book but can't find what to do with the W2 wire.
Old connections were: G, R, O, W2, C, Y (NOTE: the W2 is jumpered to L)

New connections I am assuming are going to be connected to heat pump specs. rather than conventional.
New connections: C, G, Y, O/B, RC, R & AUX, E, L
(RC and R are jumpered together, also the original W2 I have connected to AUX)
Ok guys any help would be great cause I am freezing! Thanks

upate: I jumpered the AUX and L to match the original stat, and now the emergency heat Light is on but still no heat...is my heat pump toast?
 

Last edited by s_o_wise; 03-24-05 at 05:57 PM.
  #2  
Old 03-24-05, 07:47 PM
scottg's Avatar
Member
Join Date: Dec 2004
Location: Wilmington, NC hurricane magnet of the U.S.A.
Posts: 259
Likes: 0
Received 0 Likes on 0 Posts
Well I could say to go to home depot and ask them but Honeywell has a website and a 800 number that you can call to get more info on that thermostat.
I believe that you have it wired wrong and it has to be configured to operate with your perticular system.
 
  #3  
Old 03-25-05, 05:31 AM
s_o_wise
Visiting Guest
Posts: n/a
I forgot to mention that it has been working for over a month and was working great too. The heat was always constant and never really had to mess with it. Just within the past week or two is when it just stopped working. So if it was wired wrong I don't know if it would have worked but I probably didn't have the emergency heat connected until last night. Thanks for the reply I plan to call honeywell too.
 
  #4  
Old 03-06-07, 05:44 PM
C
Member
Join Date: Mar 2007
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Same problem

I am having the same problem... it works out great but as soon as the outside temp goes really cold (-15 celsius), my thermostat shoes "heat on" but no warm air is coming out... just cold air....

I know it is not my heating system because if I remove the thermostat and plug the wires directly, it works fine...

I have only two wires from my old thermostats... I have no fan and no A/C...classic electrical heat with ducks

I'm plugged on W and R on the RTH7500D (jumper at RC as per the instructions)...I even tried to remove the jumper and it is the same thing... The website tells me that my wiring is good...

PLEASE HELP !!!

Thanks
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: