Honeywell Chronotherm III Hold-AC


  #1  
Old 12-15-07, 03:39 PM
T
Member
Thread Starter
Join Date: Dec 2007
Posts: 1
Upvotes: 0
Received 0 Upvotes on 0 Posts
Question Honeywell Chronotherm III Hold-AC

I have a Honeywell Chronotherm III electric heating system...I have three systems but one is displaying HOLD-AC and is NOT heating. I have tried replacing the batteries, checked the fuse box and made sure the doors on the air handler were correctly shut, and none of these seem to be the culprit....anymore suggestions before I call repairman? several weeks ago I had the hot surface ignitor replaced on this unit...it worked for about 2 weeks before the current problem (it is not the ignitor because I confirmed that the pilot was indeed lighting....just can't get heat to come out)
any suggestions
 
  #2  
Old 12-15-07, 06:18 PM
airman.1994's Avatar
Member
Join Date: Dec 2005
Location: VA
Posts: 5,491
Upvotes: 0
Received 8 Upvotes on 8 Posts
I believe that T-stat has a hold button on it. Have you pressed that button and if you did did the hold AC go off?
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: