Electric Furnace - no hot air

Reply

  #1  
Old 02-05-09, 08:28 AM
E
Member
Thread Starter
Join Date: Feb 2009
Posts: 3
Received 0 Votes on 0 Posts
Exclamation Electric Furnace - no hot air

Please help with advice.
I have Electric Furnace and for the last 2 weeks the air started being not hot, today was just almost cold coming out, not heating at all. The volume of air is the same, and i think the heating element went bad.

How to check it, test it and possibly repair myself without huge service bill of HVAC company?

Thank you.
Eugene
 
Sponsored Links
  #2  
Old 02-05-09, 08:31 AM
I
Forum Topic Moderator
Join Date: Feb 2005
Location: Near Lansing, Michigan
Posts: 10,944
Received 43 Votes on 41 Posts
Is this a resistive element electric furnace or a heat pump with auxiliary resistive strips?
 
  #3  
Old 02-05-09, 09:05 AM
E
Member
Thread Starter
Join Date: Feb 2009
Posts: 3
Received 0 Votes on 0 Posts
i don't know exactly the question - but the furnace looks like that - see the link
HowStuffWorks "How to Maintain a Furnace: Tips and Guidelines"
 
  #4  
Old 02-05-09, 03:31 PM
R
Member
Join Date: Apr 2007
Location: Near Buffalo, NY
Posts: 4,239
Received 1 Vote on 1 Post
Welcome to the forums, Eugene!

I'm moving this thread from the Electrical forum to a more appropriate forum where the HVAC experts there can help you find the solution.
 
  #5  
Old 02-06-09, 07:04 AM
E
Member
Thread Starter
Join Date: Feb 2009
Posts: 3
Received 0 Votes on 0 Posts
Originally Posted by Rick Johnston View Post
Welcome to the forums, Eugene!

I'm moving this thread from the Electrical forum to a more appropriate forum where the HVAC experts there can help you find the solution.
Thank you Rick for moving me to the right place in the forum.

HVAC people - if you can give a suggestion what is wrong with the electric furnace i have - i does not circulate the hot air, only cold - it gradually started being cooler and cooler and now not heating at all, the air is same force coming from the vents. Thank you very much. Eugene
 
  #6  
Old 02-08-09, 04:33 PM
C
Member
Join Date: Feb 2009
Location: Tampa Bay area
Posts: 1
Received 0 Votes on 0 Posts
Electric furnace and no hot air

I have the same problem with my Rheem that was installed about 4 years ago. I can't find any information with the model or serial numbers online.
Bill Black, Tampa, FL
 
  #7  
Old 02-22-09, 10:45 PM
Ed Imeduc's Avatar
Member
Join Date: Aug 2002
Location: Mountain Williams Missouri
Posts: 18,389
Received 0 Votes on 0 Posts
Wink

You both have a big IF. electric heat or heat pump??? Lets start are all the breaker's on to the inside unit and to the out side unit???. Are fuses good inside the unit. When you call for heat does the outside unit try to run?? If you take the front door off . Should be a schematic there to show you a lot.

ED
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: