Waterfurnace Premier2 AT045

Reply

  #1  
Old 02-23-09, 07:07 PM
Gbaird's Avatar
Member
Thread Starter
Join Date: Oct 2007
Posts: 5
Received 0 Votes on 0 Posts
Waterfurnace Premier2 AT045

Hello out there.

I have a Waterfurnace Premier system that is driving me nuts. The system would run the aux heating even though the thermostat was off. I replaced the thermostat with a Robertshaw 9720i unit. It worked well for a weekend and came home this evening from work and the system was running aux heat again and was taking the temperature in the house way past the thermostat setting. I tried turning the thermostat off and the system still ran. I tried resetting the system by powering it down and back on and the aux heat still can on. The only way that I got it to stop was to take the thermostat off.

Is there something on my system that could be making the thermostats go bad, or am I just having bad luck getting a good thermostat for my system.

Any suggestions appreciated
 
  #2  
Old 02-27-09, 06:22 PM
M
Member
Join Date: Aug 2005
Location: Missouri
Posts: 33
Received 0 Votes on 0 Posts
Gbaird. I don't have an answer but it appears you are not getting any responses from the forum. Here is a geothermal forum that will probably have some suggestions.
Geothermal Heating & Air Conditioning Forums
Hope you find a solution soon...
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: