geothermal heater not blowing warm air


  #1  
Old 04-29-09, 05:50 PM
D
Member
Thread Starter
Join Date: Feb 2002
Location: United States
Posts: 128
Received 0 Votes on 0 Posts
geothermal heater not blowing warm air

I have a geothermal heating/AC system. I don't know too much about them, so I am hoping to get some direction on how to proceed.

The blower is working, but it is blowing out cool air when I have it on heat. The thermostat has a green light that comes on sometimes. This has been going on all winter. The label on it says "em heat check". When that light comes on, the house gets cold. I could make the light go off by turning the heat down and then turning it back up. That would fix it, and it would heat the house again. Now, I don't have any heat coming out. It is just cool air. Messing with the thermostat setting doesn't help anymore.

I checked the brand and model numbers on the unit. There is a big unit that sits close to the floor. It says it is an electric heater. The brand is Century, model #WPH 044-13. Sitting on top of that is a small box. It says it is a heater. The brand is Heatrix made by Dell Corp. model # HXOB.

I appreciate any education or advice that you can give on what the problem might be and what it will take to fix it.
 
  #2  
Old 05-02-09, 08:46 AM
Jarredsdad's Avatar
Member
Join Date: Oct 2002
Location: Troy, VA
Posts: 1,527
Received 0 Votes on 0 Posts
Never heard of the units you have.

First make sure the unit has water flow. No water, no heat, no cool.
 
  #3  
Old 05-02-09, 05:55 PM
D
Member
Thread Starter
Join Date: Feb 2002
Location: United States
Posts: 128
Received 0 Votes on 0 Posts
Thanks for the feedback. Repair guy said gas was low. Filled it up. Also said that coil was beginning to rust out but that could wait.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: