Carrier heat pump/thermostat gets stuck at temp/in ON status.


  #1  
Old 01-25-11, 10:47 AM
S
Member
Thread Starter
Join Date: Jan 2003
Location: MARYLAND
Posts: 190
Received 0 Votes on 0 Posts
Carrier heat pump/thermostat gets stuck at temp/in ON status.

We have a new (less than one year old) Carrier heat pump/programmable thermostat. In the morning (and I've only seen this problem in the morning) the heat pump will go on and keep going on well after the house is well above the set temp. For example - the temp on the thermostat will read 67 (being set for 68) but a thermometer on the same wall will be reading 74 and the heat will still be on and the house will be hot - getting us out of bed to manually turn it off. The thermostat has been replaced once and we still have this problem. Again, it seems to only happen in the morning. Also it happens both when we are using the programmable feature or just having the temp set for holding one temp. Our electric bills are now higher than before this high efficiency system. Any suggestions?
 
  #2  
Old 01-25-11, 11:13 AM
Jay11J's Avatar
Member
Join Date: Sep 2001
Location: Rochester, Minnesota
Posts: 18,427
Received 0 Votes on 0 Posts
I'd call the dealer again since this less than a year old, and under warranty. sounds like the stat is the issues, and should be replaced.

As for HP, you are best to set it and forget it. . HP are not made to recover, and if you do use it, the Aux heat is going to come on and they are not cheap to run where best for the HP to maintain the temp set point.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: