Heat Pump

Reply

  #1  
Old 11-17-12, 04:11 AM
Member
Thread Starter
Join Date: Nov 2012
Location: united states
Posts: 2
Heat Pump

I have a 2 1/2 ton Nordyne heat pump which someone tried to steal. They had cut all the lines. I had AC tech. come out and hooked all back up.
The heat worked great for about one night, then no heat. He came back, and found a leak, and repaired it.
During the process of recharging the system apparently his gauge stuck, and the system was way over charged, the compressor would start and shut down in less than a minute. He proceeded to remove refrigerant, and get it back to the right amount.
Now the compressor comes on runs but no heat, low side line gets barley warm, and compressor still only runs about 5 minutes, then cuts off.

My question is could this have damaged the compressor?
 
Sponsored Links
  #2  
Old 11-17-12, 11:18 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 51,376
Upvotes Received: 206
It's possible. I'm kind of surprised that it was "way overcharged." Did you call the tech to come back ? He'll have to check pressures as well as the amp draw of the compressor.
 
  #3  
Old 11-17-12, 12:22 PM
Member
Thread Starter
Join Date: Nov 2012
Location: united states
Posts: 2
TY for replying-I called another tech to come-he said compressor is gone.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes