electric furnace not heating

Reply

  #1  
Old 12-13-13, 12:35 PM
Member
Thread Starter
Join Date: Dec 2013
Location: usa
Posts: 1
Received 0 Votes on 0 Posts
electric furnace not heating

furnace comes as it should when thermostat is moved. furnace blower everything works fine. the problem is the air coming thru the floor vents is barely warm. the little I know about furnaces is what I have read, but it seems like only one heating element is heating. could that be because the heat squencer is not working properly? thanks in advance for any help
 
Sponsored Links
  #2  
Old 12-14-13, 01:37 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 53,594
Received 417 Votes on 390 Posts
Welcome to the forums.

Yes it could be a defective element as there are usually at least two.

For starters.... a make and model number will be needed.
If you are going to attempt the repair you will need a volt-ohmmeter. Without it, don't even open the furnace up.

If you plan to repair it your self.... you'll need to turn the main power off to the electric coils, remove the access cover and take and post several well lit pictures of the relays and wiring.

http://www.doityourself.com/forum/el...-pictures.html
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description:
Your question will be posted in: