RUUD Silhouette 2 Furnace Not Working, Its Cold and I Need Some Help

Reply

  #1  
Old 02-22-14, 08:51 AM
A
Member
Thread Starter
Join Date: Feb 2014
Location: USA
Posts: 3
Received 0 Votes on 0 Posts
RUUD Silhouette 2 Furnace Not Working, Its Cold and I Need Some Help

Furnace: Ruud Silhouette 2
Circuit Board: ANS Z21.20 Automatic Ignition System, 24VAC, 60Hz, 0.5a max
Unit is probably at least 15 years old.

Woke up to a cold house, furnace fans work but no flames. Changed the ceramic ignitor, old ignitor looked fine, no cracks/breaks etc. "Old" ignitor is only two years old, I replaced it once before. This didn't solve the problem.

Startup sequence is as follows; Big exhaust fan runs for ~18 seconds then the smaller fan in the gas chamber area kicks on for ~50 seconds. The ignitor never changes color and I never smell any gas.

I used a voltage meter to test the small fan and ignitor wiring. When the small fan kicks on the wiring for it reads 120 volts for the entire run. The ignitor wiring never registers anything. I tested this at every connection and at the circuit board (they both plug into the same location on the circuit board)

Apologies for my lack of HVAC terminology, but any help would be appreciated
 
Sponsored Links
  #2  
Old 02-22-14, 09:45 AM
S
Member
Join Date: Feb 2014
Location: USA
Posts: 2,104
Received 0 Votes on 0 Posts
Check the pressure switch that is piped to the small fan. Make sure you are getting power though it.
 
  #3  
Old 02-22-14, 03:37 PM
A
Member
Thread Starter
Join Date: Feb 2014
Location: USA
Posts: 3
Received 0 Votes on 0 Posts
UPDATE, Still no heat

I checked the power to the pressure switch, it registered 26 volts (if I did it correctly).

I pulled the pressure switch tubing and cleaned it, no obstructions, some moisture.

I did notice that after the small fan shuts down, the middle green light of my three orange, green, green light sequence on the circuit board blinks twice, rests, blinks twice, rests and so on for a while. The orange light never lights during the entire process. This blinking light is labelled "OK" and "AN2"

I removed the smaller fan assembly, cleaned it and the flue, reassembled everything, and retried. Same problem.

As a rehash, ignitor is new out of box and old ignitor was two-ish years old. No power is going to the ignitor. Big fan starts, then small fan starts. Ignitor never starts.

Any suggestions?
 
  #4  
Old 02-22-14, 04:03 PM
Houston204's Avatar
Forum Topic Moderator
Join Date: Oct 2009
Location: Texas
Posts: 7,426
Received 17 Votes on 14 Posts
While it may will not help since it can be tough to get Ruud and Rheem manuals, we need the model number of the furnace.

This sure sounds like a pressure switch lockout. Does your furnace have a blinking LED code visible through the door?

If you place one lead on one side of the pressure switch and place the other lead on the second pressure switch terminal, a 24 volt reading would indicate a pressure switch lockout.

You could also measure each pressure switch terminal to common.
 
  #5  
Old 02-22-14, 08:45 PM
A
Member
Thread Starter
Join Date: Feb 2014
Location: USA
Posts: 3
Received 0 Votes on 0 Posts
Tech Specs

The tech specs on this Ruud Silhouette 2 are as follows:

Model: UGLH-07EAMGR
Circuit Board Model: 1012-920A
 
  #6  
Old 02-23-14, 10:48 AM
Houston204's Avatar
Forum Topic Moderator
Join Date: Oct 2009
Location: Texas
Posts: 7,426
Received 17 Votes on 14 Posts
I had no luck with the furnace manual.

How did you measure that pressure switch?
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: