Lennox heat pump running & running & running ...

Reply

  #1  
Old 11-21-14, 08:47 AM
Member
Thread Starter
Join Date: Aug 2010
Location: Canada
Posts: 33
Received 0 Votes on 0 Posts
Lennox heat pump running & running & running ...

The outside temp here is approx. 20 F ... I am in a relatively "tight" condo.
The HP seems to run forever to increase the inside temp 1 deg F ... no frosting on the coil that I can see.
Is this a normal condition, or should I have the system checked (pressures etc)?
Thank you
Bob
 
Sponsored Links
  #2  
Old 11-21-14, 09:44 AM
Member
Join Date: Jun 2012
Posts: 907
Received 3 Votes on 3 Posts
At 20F your heat pump, especially if it's older is struggling to really make heat. Is your auxiliary heat kicking in? Heat pumps are best kept at a steady temperature, don't drop the house at night and expect it to heat up in the frigid morning. With that said, when was the last time it was serviced? Might not hurt to let a tech come check the whole thing over and measure the temp splits.
 
  #3  
Old 11-23-14, 08:37 AM
Member
Thread Starter
Join Date: Aug 2010
Location: Canada
Posts: 33
Received 0 Votes on 0 Posts
Thank you Tom, for your suggestion. I agree ... the unit is a "bottom of the line" Lennox and has not been serviced since install (5 yrs). Perhaps I should have the "fins" cleaned out (from the inside as well - lots of "crap" in the air here ! lol
Once again, thank you
Bob
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description:
Your question will be posted in: