Heat Pump only raising air temp 10-12 deg- Filter Drier?

Reply

  #1  
Old 10-15-15, 04:49 AM
Member
Thread Starter
Join Date: Aug 2012
Posts: 10
Received 0 Votes on 0 Posts
Heat Pump only raising air temp 10-12 deg- Filter Drier?

I have a York 10 SEER heat pump from 2005. Earlier in the spring, I had the evaporator coil replaced under the home warranty that came with the house. Before that, the coil would freeze over when the AC ran. Since then, I the coil doesn't seem to freeze, but now that the heat pump is on, it doesn't seem like the temperature is rising enough (10-12 deg measured at air handler)- probably had the same issue, but not as noticeable, with the AC. I'm going to call for service, but I'm trying to think what it could be. There's always the possibility of a leak, but I noticed the filter drier was not replaced. Could this cause the problem I'm seeing? Any other thoughts?
 
Sponsored Links
  #2  
Old 10-15-15, 11:06 AM
crabjoe's Avatar
Member
Join Date: Apr 2004
Location: USA
Posts: 287
Received 0 Votes on 0 Posts
Could be anything... From the refrigerant charge to blower speed being to high.. Need more info than just saying the filter dryer wasn't changed.

BTW, do you know how the system was recharged after the evap coil was changed? Do you know if the coil uses a piston or TXV? What was the superheat/subcooling when it was recharged?
 
  #3  
Old 10-16-15, 06:41 AM
airman.1994's Avatar
Member
Join Date: Dec 2005
Location: VA
Posts: 5,795
Received 8 Votes on 8 Posts
If they didnt change the filter dryer then thats a big issue. never have those hacks back!
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: