Mitsubishi 31" TV

Reply

  #1  
Old 01-08-03, 04:39 PM
D
Doug Money
Visiting Guest
Posts: n/a
Mitsubishi 31" TV

I have a Mitsubishi 31" TV, that used to have the picture get dark with lots of red highlights. Now it is like this all of the time. Used to only be occasionally. Any help is appreciated. I am a computer tech with extensive electronics knowledge. I just never worked on a tv before. Thanks for your help.
 
Sponsored Links
  #2  
Old 01-08-03, 07:59 PM
F
FREDDYG_001
Visiting Guest
Posts: n/a
Whats the model number and date of manufacture?


Fred
 
  #3  
Old 01-09-03, 06:29 AM
D
Doug Money
Visiting Guest
Posts: n/a
CS-3131R build date: February 1991. Thanks.
 
  #4  
Old 01-09-03, 08:11 AM
M
morgan28476
Visiting Guest
Posts: n/a
Replace all 10uf, 4.7uf and 22uf minature aluminum electrolytics on PIP module. BE CAREFUL. Capacitors may have leaked and damaged the pcb traces. Replacement kit available from Tritronics. If not used, PIP module can be bypassed.
 
  #5  
Old 01-09-03, 07:14 PM
D
Doug Money
Visiting Guest
Posts: n/a
I am not really interested in Pip at this time, how can I go about excluding it. I believe it is just inserting 2 capacitors? Thanks again for your help.
 
  #6  
Old 01-10-03, 06:19 AM
M
morgan28476
Visiting Guest
Posts: n/a
Place jumper between pins 5 - 11 and between 7 - 9 on the VP connector. remove PIP board.
 
  #7  
Old 01-10-03, 06:22 AM
D
Doug Money
Visiting Guest
Posts: n/a
Thanks, I'll try it tonight.
 
  #8  
Old 01-10-03, 01:00 PM
D
Doug Money
Visiting Guest
Posts: n/a
I started on this repair. Can you give me just a little insight into which board is the pip board, and do I jumper the cable at the pip board? Thanks
 
  #9  
Old 01-10-03, 01:42 PM
D
Doug Money
Visiting Guest
Posts: n/a
I removed the pip board, it has a number 930B84360, The vp connector is toward the screen on the main board. I jumper the same plug on the main board at the spots you indicated. Do I need caps for these jumpers? Thanks.
 
  #10  
Old 01-10-03, 03:57 PM
D
Doug Money
Visiting Guest
Posts: n/a
I installed the caps in the VP socket in 5 & 11 and 7 & 9. Picture is no longer dark. It is a bit grainy. It is definately usable. Thanks. I used 10uF Electrolytic Non-polarized caps rated at 50volts. They did not have the 22uF, is this a problem? Thank you again.
 
  #11  
Old 01-12-03, 11:19 AM
F
FREDDYG_001
Visiting Guest
Posts: n/a
That might be why your picture is a little grainy, the value you used.


Fred
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: