New Zenith DVD Won't Play

Old 02-15-04, 05:02 PM
Visiting Guest
Posts: n/a
Question New Zenith DVD Won't Play

Brand new progressive scan player worked fine for first dvd. I tried to play jpegs that I burned onto a cd (this player supposedly plays mp3s, jpegs, etc) but the jpegs never worked. Now the TV won't acknowledge any inputs from the player at all -- even though it seems as if the cds and dvds are playing (the screen shows time elapsing, tracks changing). Any ideas? I've unplugged, etc.
Old 02-15-04, 06:10 PM
fewalt's Avatar
Join Date: Feb 2001
Location: sw VA
Posts: 3,020
Upvotes: 0
Received 0 Upvotes on 0 Posts
Are your component video cables still plugged in properly?
And are you selecting the correct video output on your tv/video selection button.
Are you running everything through an A/V receiver? If so you need to select DVD on the receiver.

Just a couple things to double check for,
Old 02-16-04, 04:20 AM
Join Date: Dec 1999
Location: United States
Posts: 2,484
Upvotes: 0
Received 0 Upvotes on 0 Posts
little more info, pls

Hard to speak in generalities. Tell us more about your set-up.
A/V rcvr, cable/sat hooked up, VCR hooked up, how many and what connections going to the TV.
Old 02-16-04, 06:24 AM
Visiting Guest
Posts: n/a
actually, I've unhooked all other components in order to simplify set up just to make sure it wasn't a hook up problem. I've also tried the player on two different TVs. I have another dvd player which is set up identically and works. I think the new player isn't prompting the tv to recognize it. when i hook up my old player and turn it on, the tv automatically senses it and switches from TV mode to video mode.
Old 02-16-04, 07:03 PM
Join Date: Dec 2003
Posts: 384
Upvotes: 0
Received 0 Upvotes on 0 Posts
I think you inadvertantly switched the video output in the player menus. If possible, check to see if you get picture from the composite, svideo and component jacks.

Is your tv HD compatible? If not, maybe you bumped the Progressive Scan button somewhere and that is why it's not working. There is often one on the remote.

Thread Tools
Search this Thread
Ask a Question
Question Title: