My Kenwood receiver is dead

Reply

  #1  
Old 11-16-05, 06:35 AM
five0
Visiting Guest
Posts: n/a
My Kenwood receiver is dead

I have a Kenwood VR-507 receiver and recently took a lightning strike. It is getting power but shutting off. When it is plugged in I get a solid red light on the led. When I hit the power button, the display lights up and then immediately shuts off. I then get a rapid red blinking led. If I try to re-power, it starts the same process again. I have checked the speaker wires for a short and that is not it. I guess that repairing stereos is a dying art, because there are no repair shops in the area. I don't want to spend $ on a new receiver so a little help would be appreciated. Thanks.
 
Sponsored Links
  #2  
Old 11-18-05, 07:07 PM
Member
Join Date: Dec 2003
Posts: 388
Received 0 Votes on 0 Posts
95% of 5.1 receivers are at this time not worth repairing and should be considered disposable. Your is not a part of the 5%, toss it.

try www.outpost.com for deals on refurb units. You should be able to find somehting comperable for under $200. Circuit City sells a Sherwood new for under $200 that would get the job done.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description: