Magnavox Tv Problems

Reply

  #1  
Old 11-16-05, 08:06 AM
autech
Visiting Guest
Posts: n/a
Magnavox Tv Problems

I have a maggot box (Magnavox) 14" TV Model# 14MS2331/17 that refuses to power up (No led...nothing). It's only 4 weeks old. I opened it up and did not have any obvious signs of anything wrong. No charred or burned parts. The fuse was in tact and tested fine. Anyone have any ideas?
Thanks!
 
Sponsored Links
  #2  
Old 11-16-05, 09:13 AM
Group Moderator
Join Date: Oct 2004
Location: WI/MN
Posts: 19,212
Likes Received: 33
At only four weeks old, I'd take it back - should be warranteed.
 
  #3  
Old 11-16-05, 09:59 AM
autech
Visiting Guest
Posts: n/a
Warranty Info

I tried to take it back, they would not take it back without the receipt. I have no idea where it is. They suggested I contact Magnavox. I did and they offered to repair the TV parts only...I would have to pay for labor and shipping. I considered the fact that shipping would be $25.00 and Labor would be no telling how much. The TV itself was only $70.00 + tax. I decided it would not be cost effective to try to have it repaired. I was hoping that I would discover a cap defective that I could repair for a few bucks instead of chunking it. Thanks for the reply.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes