Mitsubishi 50" VS-50705 clicks/won't turn on

Reply

  #1  
Old 02-04-07, 05:38 PM
Member
Thread Starter
Join Date: Feb 2007
Posts: 3
Received 0 Votes on 0 Posts
Mitsubishi 50" VS-50705 clicks/won't turn on

I have a Mitsubishi VS-50705 which is about 6 years old. It was in storage due to a move, and worked fine for the satellite installers up until a few days ago. We hadn't really used the TV since the install at all (we're just finishing a move). My wife's parents (who gave us the set) were average TV watchers and it worked fine for them for years.

Anyway, a few days after the installers came, the TV just "clicks" when we turn it on. The timer light is green for a half second and then goes off. In addition, while we try to turn it on, we don't see anything on the screen or hear anything other than a few "clicks" as if it's trying to start.

A friend said that he thought it was a bulb as "that was the problem" on his (different model) when it went, but I'm not too sure about that.

I have no problem trying to fix it myself, and would love any suggestions. I've read the thread, and am learning a lot, but it's hard to decipher what is meant for my set vs. others.

Thanks in advance!

-Marty
 
Sponsored Links
  #2  
Old 02-04-07, 08:07 PM
HotxxxxxxxOKC's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Location: USA
Posts: 8,044
Received 0 Votes on 0 Posts
I doubt it's the light guns. The TV set would still turn on. Was the set dropped at all during the moves? A slight fall, a few inches, could have caused the board to crack. There also might be a power amp problem.

I would recommend calling a service repair guy. Projections usually need service at the 5-6 yr mark.
 
  #3  
Old 04-20-08, 01:29 PM
Member
Thread Starter
Join Date: Feb 2007
Posts: 3
Received 0 Votes on 0 Posts
Thanks for the help Mark! Thought that I had replied already. Had a service guy come in and although it hadn't been dropped or anything, apparently some acid had dropped onto the board rendering it inoperable. Unfortunately, Mitsubishi (or anyone else) stocks replacement boards for that particular model. Lucky me. What a waste... I'm surprised being that it was relatively new, parts weren't available. I called around myself and did verify that the parts just weren't there.

Thanks for the help anyway!
 
  #4  
Old 04-20-08, 07:44 PM
HotxxxxxxxOKC's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Location: USA
Posts: 8,044
Received 0 Votes on 0 Posts
Thanks for posting back, but sorry to hear you had to heave the unit. They don't make units like they used too. Everyone is going to LCD/Plasma and no longer manufacturing parts for older sets. If you still have the set, look in for sale type adds for the same model. You could use it to cannibalize parts.
 
  #5  
Old 07-02-09, 08:02 PM
Member
Join Date: Jul 2009
Posts: 2
Received 0 Votes on 0 Posts
Smile i am new here

i don't know how to post a new thread so if anyone would like to pm me n let me know how to do it

i have a mitsubishi model #vs-60705 n it wont turn on u can hear the clicking sound
when i press the menu n input buttons together the light blinks 2 than 3 if anyone knows what it means n how can i fix my t.v. i greatly appreciate it
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description: