Zenith Z52Z95D8, No pic but sound is good

Reply

  #1  
Old 03-10-07, 05:16 PM
Member
Thread Starter
Join Date: Mar 2007
Posts: 1
Received 0 Votes on 0 Posts
Zenith Z52Z95D8, No pic but sound is good

I have a Zenith rear projection tv, model Z52Z95D8 made in sept 97. There's no picture at all but the sound is great. You can change channels cause I just listened to what was on when I changed it, so I know they change. Does anyone know what may be wrong why I get sound and no picture? Approximate cost to repair?
 
Sponsored Links
  #2  
Old 11-08-10, 01:54 PM
Member
Join Date: Nov 2010
Posts: 1
Received 0 Votes on 0 Posts
zenith Z52Z95D8 no pic but sound is good

Did you ever figure out the problem/fix. I have the exact same issue on the same model. Any help would be appreciated.
 
  #3  
Old 11-08-10, 05:22 PM
Member
Join Date: May 2008
Location: USA
Posts: 1,086
Received 0 Votes on 0 Posts
It's the high voltage/sweep module bad.Very common problem on zenith big screens.Take the back off and there is a print with a list of modules and thier part numbers.Find the part number and do a search.I don't think your going to find any parts left for this set , but good luck.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description: