help with Sony T.V....blinking VIDEO on screen


  #1  
Old 10-07-07, 09:45 AM
A
Member
Thread Starter
Join Date: Oct 2007
Posts: 1
Received 0 Votes on 0 Posts
help with Sony T.V....blinking VIDEO on screen

i've searched the forums & cannot find anyone who has listed the same problem...

my Sony TV-27in. Trinitron-OLDER model is blinking. The screen blinks when it is powered on. I just noticed that it has started doing this when it has been on for a while now. BUT now when it blinks(after being on a while) at the top left of the screen VIDEO is displayed. it continues to blink and then stops on its own. Its getting really annoying so any help with this would be greatly appreciated..thanks
 
  #2  
Old 10-07-07, 10:41 AM
HotxxxxxxxOKC's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Location: USA
Posts: 8,034
Received 0 Votes on 0 Posts
Sounds like a typical Sony problem. People spent alot of money on these sets back in the day and I tried to warn them about their failure rates back when I worked at Circuit City.....oh well.

This problem can not be properly diagnosed over a internet forum because it requires taking electrical reading on certain components in your set.

Does it blink black?

It could be your high voltage & horizontal output transistor but a qualified tech should look at it.

It may be cheap to fix, or you might as well through this dinosaur in the garbage.
 
  #3  
Old 10-31-07, 08:53 AM
zigzag's Avatar
Member
Join Date: Sep 2003
Location: cheese, milk, beer and packers
Posts: 128
Received 0 Votes on 0 Posts
Simple fix

Your Sony Tv has a circuit that takes into account the AGE of your PICTURE TUBE.
Your picture tube is weak and the fix is to turn up the screen control on the FLYBACK tranformer just a tad. It will stop the blinking and you can get a few more years out of your SONY which probably up into now never had a problem. Some SONYS have given great service for over 15years like the older sets your parents had that lasted that long.
 
  #4  
Old 01-17-10, 12:57 PM
Join Date: Jan 2010
Location: u.s.a
Posts: 1
Received 0 Votes on 0 Posts
Unhappy

hi guys...just thought to ask...my sony wega tv jus stopped working on me this morning its about 4yrs old now...was watching it and turned my back for a few and came back it was off. hasnt been back on since. been googling for answers all day...the power button was blinking rapidly at one point with no set pattern and after unplugging it from the extension it was in and trying it in the wall(read that this mite help)its now jus blinking indicating its turning on...but nothing happens then it clicks again and again and the light goes and comes...the screen does not come on whatsoever...what could i possible do to get it working again? is it time to replace it?? can it be fixed?? needless to say i'm kinda sad rite now...can anyone help plzz!


:helpme 2:
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: