Telefunken 42 Inch LCD TV, TV not switching on

Reply

  #1  
Old 06-27-14, 07:32 AM
Member
Thread Starter
Join Date: Jun 2014
Location: South Africa
Posts: 1
Received 0 Votes on 0 Posts
Telefunken 42 Inch LCD TV, TV not switching on

I have a problem with my Telefunken 42 Inch LCD TV, I plug it in to the socket and the red light on the TV comes on, I then switch the TV on using the remote or the switch on the TV, the light turns blue, if the TV switched on it would stay blue and the The screen would come on, in this case the TV light goes back to red and the screen does not come on or no sound. The serial number on the TV is 0320090068. I am in South Africa in a town called Newcastle in the province Kwa zulu Natal
 
Sponsored Links
  #2  
Old 06-27-14, 08:33 AM
Member
Join Date: Jan 2011
Location: United States
Posts: 2,446
Received 0 Votes on 0 Posts
Hi welcome to the forum. I am sorry you are having trouble with your tv I haven't worked on tv's much mainly computers. I have never heard of your brand of tv so I did some searching on the internet and someone else had the same question answered. The person on that forum said it could be in the power supply or the second main board or a sustain and scan board. None of which I am familiar with so I can't tell you what to look for. The repair did sound expensive though and it may not be worth it to repair the tv.

I normally would link you to the answer I received but I think the person who owned that tv set is going to junk it. There was no real discussion or pictures on how to repair the set. For someone to help you further here the model number of the set needs to be known and not the serial number. Also in the future please make sure you post in the appropriate area. This question should be in with the tv's and entertainment devices. I can't move this for you though you will have to wait for a moderator to move your question. Good luck to you!
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description: