Anyone had this trouble before??


  #1  
Old 05-30-02, 04:36 AM
Stan58
Visiting Guest
Posts: n/a
Anyone had this trouble before??

My RCA big screen plays good for 5 to 10 mins. then cuts off and won't turn back on for at least 30 mins. at which time the cycle repeats. Something must be overheating,....but what?? Any help will be greatly appreciated. Thanks.
Stan
 
  #2  
Old 05-30-02, 07:39 AM
Smokey
Visiting Guest
Posts: n/a
Thumbs up

Good Morning, Stan58:

Yes, I am certain someone has had this problem before.

The first place I would check is the High Voltage Regulation of the set. The high voltage to the projection tubes is regulated to some very strict limits to ensure good focus and long operating life of the tubes. If this circuit fails, the high voltage will fluctuate as the picture changes. Darker scenes will allow the voltage to rise and high brightness scenes will cause the voltage to decrease. Once it finds an "out of tolerance" condition, the set's Fail-Safe circuits will engage and turn the set off.

There are other possibilities, of course, but this is the more common failure.

To find a history of the failures and fixes of this set, here is an excellent site to review:
http://wa6ati.home.mindspring.com/Ctc169.htm

If you desire to obtain a service manual for the set, I suggest you try this site:
http://www.treasurechestcorp.com/Default.htm

For parts, I suggest you talk to our friends at Union Electronics
at http://www.unionel.com/

Smokey
 
  #3  
Old 05-31-02, 04:19 AM
Stan58
Visiting Guest
Posts: n/a
Thanks For the pointers Smokey. I am going to check them out now and see if I can get this thing straightened out.

Thanks Again

Stan
 
  #4  
Old 05-31-02, 03:15 PM
Smokey
Visiting Guest
Posts: n/a
Thumbs up

Come back and visit. We always enjoy hearing how these things turn out. If you need further information, let us know.


Smokey
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: