Dehumidifier Not Dehumidifying!

Reply

  #1  
Old 05-04-04, 02:25 PM
A
Member
Thread Starter
Join Date: May 2002
Location: USA
Posts: 115
Received 0 Votes on 0 Posts
Dehumidifier Not Dehumidifying!!!

My almost 4 year old Frigidaire dehumidifier is not running properly. i turn it on and the fan blows but i never hear the condenser kick on. it used to work last summer but at the end of the season, i noticed it not smelling so fresh in the basement and then i noticed the condenser not running the way it should/used to...

i let it go over the winter since moisture generally is less of a concern in the colder month but now i'm needing dehumidifiying and i'm out of luck (so far)...

as far as i can tell, there are no accessable areas for a DIY'er to get to and the closest 'authorized repair center' wants $50 just to look at it. there are some parts still covered by warrantee (compressor, condenser and some others that the F-A 800 operator said quite quickly) but for $50, i'd just as soon spend it on a new unit if i cannot service this myself or get an idea that its worth the $50 diagnosis and possible repair....

any thoughts? thanks in advance!!

Austin
 
  #2  
Old 10-25-04, 04:14 PM
OldmanTom
Visiting Guest
Posts: n/a
OldmanTom

Austin, I guess you mean that the compressor is not kicking in? You say the blower is working, so there is either a problem with the humidstat or the compressor is locked (not likely but it can occur). Try turning the control to continuous run. If there is still no compressor and you are confortable workin around electricity, use a jumper to bypass the humidistat. If you use a jumper BE SURE THE UNIT IS UNPLUGGED before installing the jumper. Plug the unit in and if all works, the hstat is shot.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: