Aprilaire Model 60 to Lennox Elite - Cannot get humidifier to run

Reply

  #1  
Old 02-26-13, 10:38 PM
S
Member
Thread Starter
Join Date: Feb 2013
Location: USA
Posts: 2
Received 0 Votes on 0 Posts
Aprilaire Model 60 to Lennox Elite - Cannot get humidifier to run

I just installed an aprilaire 600 hooked up to a model 60 controller on my Lennox elite furnace. Problem is that I cannot get the humidifier to turn on now, even on manual and test mode. I think it has to do with the wiring to the solenoid but need some help, so thanks in advance to whomever can help me.

I have the unit wired following the paper that was on the humidistat.
Name:  humidifer wiring.PNG
Views: 8202
Size:  30.1 KB

R, C and W are straight from the control board. and I see 24V on a multimeter at the controller on R and C (also on W and C but not on G & C unless I turn the fan from auto to on). ODT is hooked up to the temp sensor and I checked the ohm's and it appears to be working fine. I unhooked G from the control board and ran a wire from it to G on the humidistat then another wire from Gf on the humidistat back to G on the control board. The 2 H on the humidistat are hooked to the solenoid.

Not sure if this matters at all, but I do have a air cycler on the furnace as well and the wires from the thermostat run to it first then into the control board.

In looking at other diagrams it looks like the solenoid should be hooked to power as well as the humidistat but I am not certain how and where.

Please help!
Thank you
 
Sponsored Links
  #2  
Old 02-27-13, 07:39 AM
Jay11J's Avatar
Member
Join Date: Sep 2001
Location: Rochester, Minnesota
Posts: 18,427
Received 0 Votes on 0 Posts
What is the make and model of your humidifier?
 
  #3  
Old 02-27-13, 07:45 AM
S
Member
Thread Starter
Join Date: Feb 2013
Location: USA
Posts: 2
Received 0 Votes on 0 Posts
It is an Aprilaire 600 using the automatic model 60 humidistat.
 
  #4  
Old 02-27-13, 08:43 PM
Jay11J's Avatar
Member
Join Date: Sep 2001
Location: Rochester, Minnesota
Posts: 18,427
Received 0 Votes on 0 Posts
Do you have a transformer on the H side for the humidifier?? (Seen on page 16, FIG K)
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: