Aprilaire 760 Just Started Running Constantly

Reply

  #1  
Old 01-06-15, 01:27 PM
T
Member
Thread Starter
Join Date: Jan 2015
Posts: 3
Received 0 Votes on 0 Posts
Aprilaire 760 Just Started Running Constantly

I've got an Aprilaire 760 hooked up to a York Diamond 90 Gas Furnace. The AA 760 Unit is mated with an AA (aprilaire) Thermaset and it is wired into the HUM terminations on the Furnace as to run when only the heat is running. This winter I changed the Pad, cleaned the unit and now it runs CONSTANTLY (water..and what sounds like motor..though I can't tell if the fan is running).

When I turn the dial on the Humidstat down to 3 (below normal) it stops running but never re-engages. When I turn it to 4 or 5 (whats labeled as normal) water runs in pretty high volume constantly.

Any ideas on the issue and how I can tell for sure if the fan is running when the water runs? It should not be a wiring issue per se' because it's been working fine for years.

Thanks for your help!
 
Sponsored Links
  #2  
Old 01-06-15, 04:25 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 59,141
Received 1,113 Votes on 1,033 Posts
Welcome to the forums.

AA 760 Unit is mated with an AA (aprilaire) Thermaset
Is that humidistat and if yes.... what model #.... the basic manual one ?

The only way for sure to know if the fan is running inside the unit is by opening it and checking manually. Your humidifier should not work at all if the furnace blower isn't running.

Name:  760_old style.jpg
Views: 2866
Size:  50.1 KB
 
  #3  
Old 01-06-15, 06:48 PM
T
Member
Thread Starter
Join Date: Jan 2015
Posts: 3
Received 0 Votes on 0 Posts
Pjmax, Yes, it is the basic manual one with "off to 7" as the manual settings. If I put it on anything less than 4 it won't go on. If I set it to 4 or higher it runs constantly. It has worked for years where it just ran of the heat was blowing.

Thanks
 
  #4  
Old 01-06-15, 07:06 PM
T
Member
Thread Starter
Join Date: Jan 2015
Posts: 3
Received 0 Votes on 0 Posts
My bad... Was Boeing from my phone and didn't see the details of the diagram and system checks you provided. Thank you I'll review those things. I can hear the humidifier fan running when the water flows, so I think that's good.
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: