TrueEase HE250 VisionPro IAQ

Reply

  #1  
Old 02-16-15, 05:43 PM
G
Member
Thread Starter
Join Date: Feb 2015
Location: usa
Posts: 4
Received 0 Votes on 0 Posts
TrueEase HE250 VisionPro IAQ

I am reviving this old thread because I have a similar setup and can't figure out what to troubleshoot.

HE250 humidifier
TH9421C 1004 Thermostat
THM5421C 1008 EIM

dip switches
top to the right
bottom to the left

hum on he250 to hum terminals on eim
transformer to power in

when thermostat in test mode furnace circulating fan turns on but humidifier does not react

humidifier was working with manual control before new settings and eim installation

Am I missing a step?


Separated from...
http://www.doityourself.com/forum/hu...tallation.html
 

Last edited by PJmax; 02-16-15 at 06:46 PM. Reason: started new thread
Sponsored Links
  #2  
Old 02-16-15, 06:58 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 59,034
Received 1,104 Votes on 1,024 Posts
Welcome to the forums.

Not reviving that thread. You get one of your own.

The wiring connections with the EIM are very basic.

Name:  HE_250.JPG
Views: 697
Size:  43.9 KB

You'll need two wires from HUM 1 and HUM 2 on the EIM to the two HUM's on the HE-250.
A 24vac 15va transformer to POWER IN.
 
  #3  
Old 02-17-15, 05:31 AM
G
Member
Thread Starter
Join Date: Feb 2015
Location: usa
Posts: 4
Received 0 Votes on 0 Posts
Thanks, however I think I have it wired per the diagram PJmax provided which is figure 2 in my manual and it is not working.

I was looking at figure 5 Wiring TrueEase to equipment with powered terminals and wonder is my EIM considered a powered terminal? I note triangle 4 on this diagram mentions a "communicating thermostat" controlling the humidifier. Although I would not be using a sensor per triangle 2 and don't know what the correct DIP switch position should be.

So should I try with the added C wire?
 
  #4  
Old 02-17-15, 11:59 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 59,034
Received 1,104 Votes on 1,024 Posts
When you short the two HUM connections on the humidifier..... it should start running.
Check and make sure that happens so that you know the humidifier is working ok.

HUM 1 and HUM 2 are connected to a normally open relay that closes when the thermostat tells it to.
 
  #5  
Old 02-17-15, 05:32 PM
G
Member
Thread Starter
Join Date: Feb 2015
Location: usa
Posts: 4
Received 0 Votes on 0 Posts
Shorted the two humidifier terminals on the HE250. It did not start working.

It was working before the change in themostat so what do I try next?
 
  #6  
Old 02-17-15, 07:54 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 59,034
Received 1,104 Votes on 1,024 Posts
Do you have a transformer supplying the unit with 24vac on the "power in" terminals ?
 
  #7  
Old 02-18-15, 05:00 PM
G
Member
Thread Starter
Join Date: Feb 2015
Location: usa
Posts: 4
Received 0 Votes on 0 Posts
Yes transformer is supplying 24volts on the power in terminals.
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: