Yellow/Golden oily residue in water bucket

Reply

  #1  
Old 07-02-18, 07:34 PM
E
Member
Thread Starter
Join Date: Dec 2011
Location: Canada
Posts: 248
Received 0 Votes on 0 Posts
Yellow/Golden oily residue in water bucket

I have a Danby ddr60a4gp dehumidifier that doesn't dehumidify any longer. Took unit cover off and noticed coils freezing from bottom up within 15 minutes of unit being on. Temperature in basement is 70*F and we have had a lot of humidity these past 2/3 days. When I took the water bucket out I noticed a yellow/golden colour oily film sticking to the sides of the bucket. The filter is clean and the coils were in pretty good shape considering I never cleaned them in the past.

Any way, I'm thinking bad thoughts about the oily film I found. Does this indicate a leak of refrigerant or worse?
 
Sponsored Links
  #2  
Old 07-03-18, 04:44 AM
P
Group Moderator
Join Date: Mar 2003
Location: NC, USA
Posts: 23,746
Received 631 Votes on 583 Posts
I'd say it's time to shop for a new dehumidifier. They are mostly not repairable and seem to have a life of 3-10 years. I guess your unit has a leak. The refrigerant leaked out and the residue you are seeing is the oil... that should be on the inside.
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: