Febco 765-1

Reply

  #1  
Old 04-08-12, 07:29 PM
Member
Thread Starter
Join Date: Sep 2006
Location: USA
Posts: 21
Febco 765-1

I went to start up my system today, and noticed water coming from the top of the BVP. I then went and moved the ball valves for the inlet and outlet. I realized after some more research that this was not necessary. Anyway, once I went to start the water through a second time, water was pouring from the bottom (see red arrow). Did moving the ball valve to close then open get it frozen in the closed position? I'm guessing that this will require the BVP to be replaced? Any assistance would be appreciated.

 
Sponsored Links
  #2  
Old 04-09-12, 05:00 PM
Member
Join Date: Nov 2008
Location: mid-west
Posts: 186
the arrow is pointing to the drain in the pipe either that or the pipe froze, make sure there is a plug in there or replace pipe... you can purchase the poppett kit for this Bac-flo for about $30 it is very easy to replace...make sure water is off.
 
  #3  
Old 04-09-12, 07:31 PM
Member
Thread Starter
Join Date: Sep 2006
Location: USA
Posts: 21
Thanks wannabe. I'm assuming that there was a plug there the first time I went to start it, and it must have blown out the second time. Weird I guess. THanks for your help.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'