Utilitech 7-Day Digital In-Wall Timer Installation

Reply

  #1  
Old 09-30-10, 05:44 PM
L
Member
Thread Starter
Join Date: Sep 2010
Location: USA
Posts: 1
Received 0 Votes on 0 Posts
Utilitech 7-Day Digital In-Wall Timer Installation

I'm having problems. This replacement timer is to be installed as one of 3 switches on a 3-gang panel. (House was built in 2002). Connected green to bare copper ground, white to gang of white neutrals. By process of elimination I connected the timer black to black and timer red to other black. When I reversed the blacks, no juice flowed to the timer. Now when I push the "on" button on the timer, it lights up, and the display flickers. I can't set the clock or program the timer. Nor did the lights that were to be controlled go on. I thought maybe the timer itself was defective so tried another new timer--same result. Help! I don't know what else to do.
 
  #2  
Old 09-30-10, 06:35 PM
R
Member
Join Date: May 2005
Location: South Florida
Posts: 137
Received 0 Votes on 0 Posts
Sounds like you have no power. I think the display is working because of the battery back up.

Try connecting the 2 blacks from the switch box together without the timer. Turn the breaker back on and the light should come on if you have power there.

Also post a picture if you can
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: