Regency fan remote control issue

Reply

  #1  
Old 11-13-15, 06:13 PM
Member
Thread Starter
Join Date: Nov 2015
Location: USA
Posts: 1
Regency fan remote control issue

My Regency fan works fine with the wall control but I'm having remote control problems. The remote control will turn the fan off, on and control all three speeds as long as the light is OFF. However if you turn the light on first, you have to be within a foot of the fan itself to operate any other function, including turning the light back off. It's like when the light is on it's creating a 'force field" that the remote signal can't penetrate. The fan is only a year old and it's been like this since day one. I purchased a new "universal" remote thinking the one that came with the fan was bad but had the same results. Any suggestions?
 
Sponsored Links
  #2  
Old 11-13-15, 07:39 PM
Member
Join Date: Sep 2015
Location: US
Posts: 377
Likes Received: 2
I can't overlook the obvious, so have you put new batteries in the remote. If you have CFL or LED lamps in the fan, the most likely problem is the switched-mode power supply in the lamp(s) is creating interference. For all practical purposes, the receiver is being overloaded with noise from the lamp(s).

If you have other lamps of the same size, try moving them into the fan. Otherwise, buy a different brand lamp.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes