Brand new attic fan not working

Reply

  #1  
Old 07-30-16, 03:49 PM
Member
Thread Starter
Join Date: Jul 2016
Posts: 21
Received 0 Votes on 0 Posts
Brand new attic fan not working

i installed an attic fan today, wired it all up and its not powering on. it has power ran to it. i was testing the voltage with a multimeter, and i touched a power lead to the back of the thermostat it sparked but turned on for a second. i have very little electrical knowledge any help is appreciated
 
Sponsored Links
  #2  
Old 07-30-16, 03:53 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 53,051
Received 370 Votes on 347 Posts
Welcome to the forums.

Is this a rooftop attic fan with self contained thermostat ?
You need to turn that thermostat to test the operation.
 
  #3  
Old 07-30-16, 03:55 PM
Member
Thread Starter
Join Date: Jul 2016
Posts: 21
Received 0 Votes on 0 Posts
yes, its an adjustable temperature thermostat. i've played around with the little knob and no dice.
 
  #4  
Old 07-30-16, 04:18 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 53,051
Received 370 Votes on 347 Posts
You can try shorting out the two wires on the back of the thermostat. If the fan works.... the thermostat is defective.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description:
Your question will be posted in: