5.7L engin OMC

Reply

  #1  
Old 08-01-02, 05:37 PM
imphil
Visiting Guest
Posts: n/a
Angry 5.7L engin OMC

When I take my boat out and apply 2500RPM it looses power and backfires. I have replaced the ignition points with an eletronic ignition and replaced cap and wireing and plugs and it still backfires and looses power. When I back off on the power it runs corectly? I have allso checked the timming 8 BTDC. What is causing this problem? It is a 1988 GMC 5.7L cobra outdrive on a 25 foot Rennel boat
 
Sponsored Links
  #2  
Old 08-01-02, 08:05 PM
BoatMech's Avatar
Member
Join Date: Dec 1999
Location: Los angeles
Posts: 592
It could be the carburettor is running lean in the secondary.
It also could be that the shift module is being activated by
the incompatible ignition system.
Did you read the part about not being compatible in the
instruction book? Many systems do not work with the
OMC cut out module.
scott
 
  #3  
Old 08-02-02, 10:05 AM
imphil
Visiting Guest
Posts: n/a
Reply

Thanks Boatmech, I did a compression test tonight and I think I have major problems. cylinders 6&8 Have 15 PSI and 3&5 have 60 psi all the rest have 170 psi Does this sound like a head gasket or valves? If I need a new engin wear can I find one or have this one rebuild fast? I live in Valdez, Alaska.
 
  #4  
Old 08-03-02, 07:30 PM
BoatMech's Avatar
Member
Join Date: Dec 1999
Location: Los angeles
Posts: 592
poor ignition timing caused burnt valves.
just pull the heads and look at the pistons.
You will probably get by with just new intake
valves. Felpro makes a good gasket set.
scott
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes