95 seadoo speedster no spark at all

Reply

  #1  
Old 07-01-05, 06:21 PM
holotoftrouble
Visiting Guest
Posts: n/a
95 seadoo speedster no spark at all

need help here,i have a 95 speedster and i have no spark at all,the plugs are from bombardier and gaped good,i changed the cdi,i changed the starter,all the grounds are good,i checked the cut off switch and key switch and everything is good,and also the fuses and starter silinoid and all is good so any help would be apreciated,tks man!
 
Sponsored Links
  #2  
Old 07-03-05, 09:47 AM
Member
Join Date: Apr 2005
Posts: 31
I am not very familiar with PWC's but have worked on many bombardier engines. That being said. If you know your CDI and wiring are good I would check the ignition coil. Good luck. MIKE
 
  #3  
Old 07-03-05, 06:45 PM
holotoftrouble
Visiting Guest
Posts: n/a
my seadoo

Originally Posted by mcope66
I am not very familiar with PWC's but have worked on many bombardier engines. That being said. If you know your CDI and wiring are good I would check the ignition coil. Good luck. MIKE
tks for getting back to me dude,the cdi is good and the wiring is good and i'm even sure the ignition coil is good, my buddy tested it......the engine turns but there's just no spark,if the coils was toast,the engine wouldn't turn,would it???maybe there's a better way to test the ignition coil,please let me know!
thanks again dude.............the thing is when i was driving the boat along at full throttle,then i decided to slow down so when i put the throttle down it just stalled and then no spark fron then on..
 
  #4  
Old 07-03-05, 07:20 PM
holotoftrouble
Visiting Guest
Posts: n/a
my seadoo

just one more thing,you told me i should check the ingnition coil but i think thats what i call cdi????
 
  #5  
Old 07-04-05, 09:07 AM
williamr
Visiting Guest
Posts: n/a
simillar?

I dont know if they are similar at all, but my dad and i wee getting no spark on our out board motor. we replaced the ignition switch and a coil, turns out the key on the fly wheel was sheared, when we replaced that it fired right up. after spending $60 replacing good parts it was a 26cent part that did the trick. Good luck!
 

Last edited by williamr; 07-04-05 at 10:18 AM.
  #6  
Old 07-04-05, 04:24 PM
Member
Join Date: Jul 2003
Location: Richmond,Va
Posts: 30
Speedster

Search Seadoo forums at www.jetboating.net
 
  #7  
Old 07-05-05, 08:51 AM
holotoftrouble
Visiting Guest
Posts: n/a
my seadoo

tks for the help guys,i found the problem.....it was the dam starter relay,i didn't think that it would cause no spark at all,but thats cool im back on the water........wooooooohooooooo!
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 02:28 PM.