Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

power trim problem


mrock's Avatar
Visiting Guest

Posts: n/a

09-30-05, 08:56 AM   #1  
mrock
power trim problem

I have a 18' Sea Ray with Mercury 3.0 and Mercruiser Alpha 1 stern drive. My problem is that the drive unit trims/tilts down with no problem, but won't trim up.
It will trim up with the trailer button, but not the up/down toggle switch. Could this be just a switch problem? I think that there is a limit sensor on it, could this be the problem? Any advice is appreciated

 
Sponsored Links
Savannah Dan's Avatar
Member

Join Date: Oct 2005
Posts: 38

10-07-05, 12:17 PM   #2  
Everybody has this problem with their Mercruiser eventually. There is a trim limit switch in the outdrive that is there to keep you from trimming the engine up too much when you are under way. This helps prolong the life of the u-joints in the outdrive. The insulation on the wires where they pass through the bell housing wears off and the trim limit switch quits working. It is an expensive switch, and the outdrive and bell housing have to come off to replace it. Most people just let it go. If you do, use your trim indicator to make sure you don't raise the motor too high with he trailer switch while the motor is running.

If you are real lucky, your trim switch up front is bad, but we never get that lucky with a boat, do we?

 
Search this Thread