mercruiser stumped

Reply

  #1  
Old 08-11-06, 04:16 PM
Member
Thread Starter
Join Date: Aug 2006
Posts: 1
mercruiser stumped

After removing my distibutor from my mercruiser 260, 350GM small block to remove rusted screws it won't go back in. I'm a auto mechanic and have never seen this problem. It will get to about 1/2 inch from setting when it "binds". Almost like the bushings have expanded. The gear engages fine, and the oil pump slot doesn't seem to be an issue. The distributor binds so tight it almost gets stuck in the block. Any ideas??
Thanks, Bob
 
Sponsored Links
  #2  
Old 08-12-06, 04:45 AM
fellowesman's Avatar
Member
Join Date: Jul 2006
Posts: 13
check the "o" ring that seals the upper shaft may have swelled up
not letting it seat all the way down. i dont think that it would bind
that hard the only other thing that will hold it up is the oil pump
shaft not lined up
 
  #3  
Old 08-17-06, 03:44 PM
Member
Join Date: Jul 2006
Posts: 17
thats about how far it gets for me when i try to do them, but usually twisting them a little with pressure gets them to go down for me
 
  #4  
Old 08-21-06, 06:06 PM
Pwrbait
Visiting Guest
Posts: n/a
Have you had any luck with this operation yet?
-Chris
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes