350 chev marine eng problems


  #1  
Old 05-18-07, 09:40 PM
F
Member
Thread Starter
Join Date: May 2007
Posts: 2
Upvotes: 0
Received 0 Upvotes on 0 Posts
Unhappy 350 chev marine eng problems

i just finished having my 350 chev fresh water cooled eng rebuilt and when you start the engine after about 3 to 5 minutes into the run it starts reving up from 1500rpms to 2000rpms, then it will fall on its face then rev back up. then it will make a sound very simular to a valve losing prime. then once the eng warms up it appears to go away. i have not yet sea trailed this engine so i don't know what it will do with a load. same man rebuilt the other eng just a few months ago and it runs perfect.

we built both eng with flate head pistons and an oversize marine cam to develop more hourse power.

we,ve checked everthing possible, but we are stumped
please help
 
  #2  
Old 05-19-07, 05:18 AM
T
Member
Join Date: Aug 2005
Posts: 2,128
Upvotes: 0
Received 2 Upvotes on 2 Posts
carburated or fuel injected? If I were to guess, based on the information, I would think your engine is surging due to going from a regular/rich mixture to a lean mixture (air/vacuum leak) and back again.
 
  #3  
Old 05-19-07, 09:14 PM
F
Member
Thread Starter
Join Date: May 2007
Posts: 2
Upvotes: 0
Received 0 Upvotes on 0 Posts
edelbrock 4 barrel, ill take a closer look at the carb. thanks, ill update
 
  #4  
Old 05-21-07, 06:47 AM
T
Member
Join Date: Aug 2005
Posts: 2,128
Upvotes: 0
Received 2 Upvotes on 2 Posts
That's what I thought.... check your fuel pump for good pressure.... Don't forget the fuel filter..... check your float valve/valve seat for sticking...... double check your float level.

I'll bet a dollar against a donut that your carburation is the issue.....
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: