Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Boat Speedometer Ceased Functioning


Texas Mark's Avatar
Member

Join Date: Jun 2009
Posts: 1

06-26-09, 09:26 AM   #1  
Boat Speedometer Ceased Functioning

Recently purchased a used Sea Hunt that had been sporadically used and garage kept. On one of the first runs out, the speedometer was registering fine and after about 10 minutes it ceased to function and speed went to 0. I suspect the pitot may be plugged, but am not sure. Any advice on how to troubleshoot and possible causes?

 
Sponsored Links
stephen44's Avatar
Member

Join Date: May 2009
Posts: 11
VA

06-26-09, 12:28 PM   #2  
Posted By: Texas Mark Recently purchased a used Sea Hunt that had been sporadically used and garage kept. On one of the first runs out, the speedometer was registering fine and after about 10 minutes it ceased to function and speed went to 0. I suspect the pitot may be plugged, but am not sure. Any advice on how to troubleshoot and possible causes?
i disconnect at speedometer end - should get stream of water out -if not the fault blockage is further back - disconnect pipe at engine - stream now ?

based on results you should be able to determine where fault is. I have success by blowing backwards with compressed air to clear - hope this helps

Stephen

 
chandler's Avatar
Banned. Rule And/Or Policy Violation

Join Date: Dec 2005
Posts: 39,968
GA

06-26-09, 02:28 PM   #3  
Or do as I did, sit there wondering why I had a very small leak along my right gunwale. A rat had chewed through the pitot tubing and it was dripping causing erratic speedometer readings. Double barb connector fixed it right up.

 
Search this Thread