OMC Tilt/Trim Goes up but not down

Reply

  #1  
Old 08-18-09, 03:18 PM
Member
Thread Starter
Join Date: Apr 2007
Location: SO MO
Posts: 110
OMC Tilt/Trim Goes up but not down

Hello, I got a 1992 Johnson 120 HP V4 with OMC Tilt/Trim. It worked fine last year. I was just messing with it to take it out this weekend. The Tilt raises the motor up perfect and strong but it will not lower it. Have to use the manual release to get it back down. Where do I check the fluid at? Any ideas about why it will go up and not down? Thanks.
 
Sponsored Links
  #2  
Old 08-18-09, 05:35 PM
Member
Join Date: Jul 2008
Location: Montgomery MN
Posts: 541
Look for 2 relays next to eachother. one is for up the other down. Swap them and I bet it will go down if it does that's your problem. Bring one of the old ones in to a auto parts store they will have what you need.

If that doesn't work I would look at your switch you should have power 12v on the red wire in the up position there will be power to the blue wire in the down position it will power the green.

Have a good day on the water.
 
  #3  
Old 08-19-09, 04:54 PM
Member
Thread Starter
Join Date: Apr 2007
Location: SO MO
Posts: 110
Thanks for the input. Trim is working perfect once again. For future reference where do I check/fill the fluid at?
 
  #4  
Old 08-19-09, 05:07 PM
Member
Join Date: Jul 2008
Location: Montgomery MN
Posts: 541
Trim the motor all the way up and put the lock in place so it doesn't fall on you. There will be a flad headed screw on the back. I rarly see low fluid level, the symptoms are it won't trimm all the way up and will jump at it's top travel because it's pumping air.

Good to hear it's working, I would pick up a relay and keep it on board. If it failed once it will fail again If you have one with you can replace it on the water.
 
  #5  
Old 09-18-09, 06:44 AM
Member
Join Date: Sep 2009
Location: fort myers
Posts: 1
help finding the relays

hello my 1996 evinrude 120hp is doing the same up but not down. were would i find the relays

thanks



Originally Posted by samuari View Post
Look for 2 relays next to eachother. one is for up the other down. Swap them and I bet it will go down if it does that's your problem. Bring one of the old ones in to a auto parts store they will have what you need.

If that doesn't work I would look at your switch you should have power 12v on the red wire in the up position there will be power to the blue wire in the down position it will power the green.

Have a good day on the water.
 
  #6  
Old 09-18-09, 08:51 PM
Member
Join Date: Jul 2008
Location: Montgomery MN
Posts: 541
I think they are monted on the port side on the top carb between the air box and carb.
 
  #7  
Old 02-03-10, 05:21 PM
Member
Join Date: Feb 2010
Posts: 1
Thanks

Thanks Samuari you fixed the issue I was having with my trim tilt was the relay cheers
 
  #8  
Old 08-21-10, 02:55 PM
Member
Thread Starter
Join Date: Apr 2007
Location: SO MO
Posts: 110
Hey! My trim started acting up again this season, so I changed the relays. Works perfect-Thanks a ton! Marine supply wanted $13 each but the Auto Z matched it up for $7.
Thanks again for the help-
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes