No power Mercury fifty classic

Reply

  #1  
Old 08-23-09, 03:15 PM
Member
Thread Starter
Join Date: Jan 2009
Location: Ottawa Canada
Posts: 72
No power Mercury fifty classic

I was given the stator by the owner the first one that he gave me was not the right one it was for a 3 cylinder and his motor is a mercury classis 50 he returned it to the dealer and recived one NO 398-832075A14 installed it on the motor turned the ignition key engine and it fired up right a way owner took out the boat for a run said it did not have full power.
On rexemaning the enging I detected a leak on the intake manifold gasket I installa new gasket
I tried to ckeck the timing,I tryed 2 different timing lights none of theme worked
I tryed my timing light on my boat it worked alright
the owner tryed his boat again and telles me there is still no power at high speed
it is a fifty clasic OA736979
Any help or suggestions would be appericated
 
Sponsored Links
  #2  
Old 08-25-09, 07:09 PM
Member
Join Date: Jul 2008
Location: Montgomery MN
Posts: 541
look at the basics spark fuel and compression.

You can get some neat inline spark testers cheap from a auto parts store that way you can run the engine and see the spark.
I use a regular automotive timing lite and it works fine, I wonder if your spark is weak.
 
  #3  
Old 08-26-09, 05:09 PM
Member
Thread Starter
Join Date: Jan 2009
Location: Ottawa Canada
Posts: 72
Originally Posted by samuari View Post
look at the basics spark fuel and compression.

You can get some neat inline spark testers cheap from a auto parts store that way you can run the engine and see the spark.
I use a regular automotive timing lite and it works fine, I wonder if your spark is weak.
Thanks Samuari
I will Take the compresion tomorrow also install my spark tester to check the spark while the engine is running will keep you posted

Petrie
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes