470 mercruiser 1979

Reply

  #1  
Old 11-14-01, 11:54 AM
Visiting Guest
Posts: n/a
470 mercruiser 1979

hi I am rebuilding a 470 mercruiser engine 1979 I changed and serviced the head and gaskets my problem is I still see oill in the water, i replace the seals on the water pump and the cam shaft.
some one told me is the oil cooler is that possible and where is located.
best regards
 
Sponsored Links
  #2  
Old 11-15-01, 02:42 PM
BoatMech's Avatar
Member
Join Date: Dec 1999
Location: Los angeles
Posts: 592
Have you pressure checked the cooling system,
i have seen a lot of deteroioration of the cylinder
liner aluminum which causes premature gasket failures.
Also is the weep hole to the water pump seals clear?
let me know. scott
 
  #3  
Old 11-18-01, 01:20 PM
Visiting Guest
Posts: n/a
470 mercruiser

thanks for your reply
yes the weep hole is clear
any pssible the salt water gets into the oil ?
what are the possiblelity that the water gets into the oil
any thing i can do without stipping the engine again.
thanks you for your help and support
 
  #4  
Old 11-21-01, 04:07 PM
BoatMech's Avatar
Member
Join Date: Dec 1999
Location: Los angeles
Posts: 592
Your going to have to preassure check the cooling system.
If the closed system is OK then the exhaust manifold, elbow,
or gasket is leaking water into the engine thru the exhaust.
I hope you dont have to take it apart again. scott
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes