Ski Doo Blowing Bulbs

Reply

  #1  
Old 11-15-05, 06:18 AM
Member
Thread Starter
Join Date: May 2004
Posts: 15
Ski Doo Blowing Bulbs

I have a 1996 Ski Doo Touring LE 440cc fan with 1800 miles & electric start. At the end of last season, a headlight bulb blew, I replaced it, and the second one blew. I then installed a new Rectifier/VR, and put the sled away for the summer. Yesterday (Nov 14) I started it (using the electric start) and after a minute or so, the headlight & taillight blew. I'm not sure what to try next.

Any suggestions?
 
Sponsored Links
  #2  
Old 12-31-05, 05:50 PM
booneman
Visiting Guest
Posts: n/a
bulbs

Maybe there's a bad ground somewhere on the body or a live wire exposed
 
  #3  
Old 12-31-05, 09:23 PM
Member
Join Date: Feb 2005
Location: Michigan
Posts: 335
Take a meter and test the voltages at both sockets, and compare that to the current the stock bulb is made to handle. Do you have a schmetic?
 
  #4  
Old 01-04-06, 06:12 AM
Member
Join Date: Jan 2006
Posts: 10
Vr

What you have is a defective voltage regulator. Make sure the battery is at full charge. Buy a new regulator, Put it in and your off. Denniskirk.com has them for 35. bucks. I just used one from a motorcycle I have and works great. Before that I had the same trouble as you(with the same sled) GOOD LUCK
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'