No spark

Reply

  #1  
Old 01-22-06, 12:58 PM
Member
Thread Starter
Join Date: Sep 2004
Location: Saskatchewan
Posts: 175
No spark

Got a 93 ski-doo skandic 377,The boy was out riding it and it quit,their is no spark in either plug.was no warning of anykind it just died was runnin great
Any ideas or suggestions???
 
Sponsored Links
  #2  
Old 01-23-06, 02:31 AM
Member
Join Date: Jan 2006
Posts: 107
No Spark

Hi, Check and see if he might have accidentally hit the emergency kill engine button.
 

Last edited by Jeff Z; 01-23-06 at 04:56 AM.
  #3  
Old 01-28-06, 07:09 AM
puey61's Avatar
Member
Join Date: Apr 2004
Location: Upstate New York
Posts: 3,224
Don't overlook the obvious...check the spark plugs for failure by trying two new ones. If this is not it then it may be: open ground (short) in the kill system, stator, ignitor or the electronic box. Anything electrical is usually difficult to pinpoint. Good luck.
 
  #4  
Old 02-13-06, 08:24 AM
diagnosticmonke
Visiting Guest
Posts: n/a
Kill_switch

Some of those kill swiches ran of both open and grounded circuits. Diconnect the kill swich wire all together, check for spark. then try gounding the kill switch wire, check for spark. Does this model also have a tether cord to a switch ???
 
  #5  
Old 02-19-06, 07:42 PM
Member
Thread Starter
Join Date: Sep 2004
Location: Saskatchewan
Posts: 175
Thanks all It was CDI
 

Last edited by ski332; 02-20-06 at 05:54 PM.
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'