Need helpwith a Go-Kart with OHH60 Tecumseh Engine

Reply

  #1  
Old 04-25-06, 07:10 PM
Member
Thread Starter
Join Date: Apr 2006
Posts: 2
Question Need helpwith a Go-Kart with OHH60 Tecumseh Engine

Hello everyone here,
I need some help fixing a Manco Quicksilver 2X6 GL with OHH60 Tecumseh Enigne
I am having 2 problems Here they are:
1. The Go-Kart won't start!:
When you pull the pull-cord on the engine (Tecumseh Power Sport) instead of trying to start the engine it just makes the Kart move backwards! I don't know why this happening but it maybe linked to my next problem
2. The Go-Kart does not go backwards when pulled!
When I pull backwards on the Go-Kart it just stays put and the brakes come in! I looked this over and I think that the disc brake on the back axle is not correctly seated (for lack of better way to explain it) and even when the brake pedal is not pushed in
Anyone got any ideas?
Thanks In Advance for Any help!,
-TBird
PS: If someone could give me a link to some mechanical drawings for this Kart (Manco Quicksilver 2X6 GL) I would really Appreciate it!
 
Sponsored Links
  #2  
Old 04-25-06, 07:14 PM
Member
Thread Starter
Join Date: Apr 2006
Posts: 2
Arrow

I already checked out this old archived topic and it helped a lot with question #1: http://forum.doityourself.com/archiv.../t-147655.html
But I still need help with question #2
Thanks in Advance for any help!,
-TBird
 
  #3  
Old 04-25-06, 07:33 PM
Member
Join Date: Jan 2006
Posts: 107
Hi, Check out
http://www.gokartsrus.com/manco-485-...sid=2ccfa40f9f

Look around on their site.

Best regards, Jeff Z.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'