kawasaki fd 620 engine timing

Reply

  #1  
Old 01-17-08, 11:51 AM
Member
Thread Starter
Join Date: Jan 2008
Posts: 3
kawasaki fd 620 engine timing

i am having trouble getting my engine timed on my mule. ive done everything by the manual but still no go. backfiring through the intake gas in the oil. i know they changed from a plastic cam gear to a steel gear are thr timing marks supposed to be lined up different now?????????????? HELP!!!!!!!!!!!!!!
 
Sponsored Links
  #2  
Old 01-17-08, 05:15 PM
Member
Join Date: May 2006
Location: Iowa!!!!!
Posts: 3,769
The timing marks should line up the same. What all have you done to it. Were you replacing the cam and it started backfiring or did this just start while running it?
 
  #3  
Old 01-17-08, 05:27 PM
Member
Thread Starter
Join Date: Jan 2008
Posts: 3
i rebuilt the entire engine but the cam and the heads came out of another 620. i was told this wouldn't matter. i've got gasoline in the oil, when i try to start it it "hangs" with the choke on, crank its but off with the choke off, good coils, good spark, i had this problem with the last one i rebuilt, thought it was put together wrong or something. i have rebuilt probably 6 of these no problem but the last 2 are killing me
 
  #4  
Old 01-17-08, 06:00 PM
Member
Join Date: May 2006
Location: Iowa!!!!!
Posts: 3,769
Sounds like ignition timing/carburetion. More on the timing. Cam timing shouldn't put gas in the oil.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes