Heritage Softail turn signal wiring problem

Reply

  #1  
Old 04-06-08, 06:36 PM
Member
Thread Starter
Join Date: Dec 2002
Location: Pittsburgh, PA
Posts: 553
Heritage Softail turn signal wiring problem

I'm helping a friend build a custom Harley from a Heritage softail. Without boring you with the details... when the rear tail lights are disconnected, the front turn signals work, of course they don't flash but they work. If we disconnect the front and connect the rear the rears work, again no flashing. If we plug them all in, they don't work at all! If I unplug the rear and say turn on the right signal then plug in the rear connector it works and even flashes... what the heck! The frame has been powder coated and we cleaned the ground up under the tank and in the back by the battery. We even tried to connect a temporary ground from the battery to the rear and front lights, no change. What causes the turn signals to flash? We tried removing the turn signal return module and cleaning the connector as well as the other three up under the tank.

Any suggestions
 
Sponsored Links
  #2  
Old 04-12-08, 08:42 AM
Member
Thread Starter
Join Date: Dec 2002
Location: Pittsburgh, PA
Posts: 553
Well, we figured it out..... we traced wires and studied the wiring diagram and could not see any problems. My buddy called me from the local Harley shop and he said that they had a turn signal return module in stock for about $125. Rather than take a chance on someone else buying it and he having to wait (which I advised against) he bought it anyway. I told him that since it's electrical once you buy it you own it. Guess what, it fixed it! I think that after a few more hours we would have come to that conclusion anyway, but to shell out $125 on a guess was tough. Really there wasn't anything else in the circuit but that, but the combination of the wiring diagram being SO SMALL that you can't hardly read it, being unfamilliar with the problem, and the unbeilivable coincidence that it worked before he tore it down and now it doesn't, we just couldn't believe that it ws bad. I guess we shouldn't be shocked, the light in the tach quit too. It too worked before he tore it down.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes