1996 Polaris Indy Light 340 problems:( Need Help!

Reply

  #1  
Old 01-06-09, 08:18 PM
Member
Thread Starter
Join Date: Jan 2009
Posts: 2
Question 1996 Polaris Indy Light 340 problems:( Need Help!

OK so heres the problem i have a polaris indy light and that i have bought. For the firstt couple of weeks i had it it ran smooth without a problems then not too long after it started to bog out when i started it and wouldnt go over 10-15 kms an hour but after a little while driving it would get all its power back in a sudden moment and nearly throw me off it.. Now when i start it up it just will not have any power and i dont know what the problem is the sled will not go anyfaster then 7 or 8 kms and it has barley enough power to move itself. I would love to find out the answer to this problem its a twin cylinder with dual carbs i dono if the carbourators or some seals or gaskets are gone i dont have much knowledge about snowmobiles. IF ANYONE MIGHT KNOW THE PROBLEM YOUR HELP WOULD BE GREATLY APPRECIATED!!!
 
Sponsored Links
  #2  
Old 01-13-09, 12:25 PM
Join Date: Jan 2009
Location: alberta
Posts: 16
indy lite

what do the spark plugs look like when u take them out?
 
  #3  
Old 02-01-09, 05:12 PM
Join Date: Jan 2009
Location: alberta
Posts: 16
did u get the problem solved?
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'